exclamation-circle Joomla 4.1.2 - SEF beállítás módosítása után jött a „Vörös Ördög”

Több
2022 ápr. 12 18:05 - 2022 ápr. 12 18:07 #1 Írta: Zotius
A Globális konfigurációban, a SEF beállítások között csupán egy módosítást végeztem (SEF utótag NEM-ről IGEN-re állítást), de inkább ne tettem volna...
A módosítás után jött vörös háttéren az alábbi üzenet:
Sajnáljuk, de egy olyan hiba történt, amelyet nem sikerült megoldanunk.
The server returned a "500 - Whoops, looks like something went wrong."
hibaüzenet.
Próbálkoztam a configuration.php-ban az alábbi paraméterek "false"-ra visszaállításával, de eredménytelenül.
public $sef = false;
public $sef_rewrite = false;
public $sef_suffix = false;
public $unicodeslugs = false;
Mi tévő legyek, hogy ismét életre keljen az oldal?
 

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius
Utolsó szerkesztés: 2022 ápr. 12 18:07 Zotius által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 12 18:22 - 2022 ápr. 12 18:25 #2 Írta: Zotius
A configuration.php-ban bekapcsoltam a debug funkciót. A debug eredménye az alábbi:


A migrált oldal ezen az URL-en látható.
 

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius
Mellékletek:
Utolsó szerkesztés: 2022 ápr. 12 18:25 Zotius által. Indoklás: kép csatolása

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 13 15:28 - 2022 ápr. 13 15:29 #3 Írta: Balázs
A Redis az inkább cache probléma. Erre dob valamit?
Globális konfiguráció -> Rendszer -> Gyorsítótár -> Rendszer gyorsítótár -> KI (configuration.php -> public $caching = 0;)

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2022 ápr. 13 15:29 Balázs által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 13 19:16 #4 Írta: Zotius
A gyorsítótár a migrálás után nem változott, ki van kapcsolva.
A régi J3x nél a munkamenet kezelő "Nincs"-re volt állítva.
A backupból, az újbóli telepítés és megismételt J3x > J4x frissítés után - után épp az imént néztem -, hogy az alapértelmezett munkamenet kezelő Redis lett.
Úgy látszik, hogy valami rendesen összeakadt a Redis-szel.
Megpróbáljam "Nincs"-re állítani?

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 14 08:05 #5 Írta: Balázs
Szerintem a Redis nincs megfelelően bekonfigurálva a szerveren, így összeakad, ezt ki kellene kapcsolni.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
A következő felhasználók mondtak köszönetet: Zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 14 10:42 #6 Írta: Zotius
Eltérések vannak a J!3 és a J!4 munkamenet-kezelőjének opciói között:
J!3-nál:  Redis | Nincs | Adatbázis,   >>> a beállított: Nincs
J!4-nél:  Redis | Fájlrendszer | Adatbázis
   >>> a beállított: Redis
Bár most, a másodszori frissítés/telepítés után jól működik, ki merjem kapcsolni?

Ha ki akarom kapcsolni, állíthatom "Fájlrendszer"-re? (Ez felel meg a J3-nál a "Nincs" opciónak)

 

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 ápr. 14 12:10 #7 Írta: Balázs
Szerintem állíthatod fájlrendszerre, ez a beállítás nem szabadna, hogy gondot okozzon.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
A következő felhasználók mondtak köszönetet: Zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!