Többünkkel előfordulhatott már, hogy be szerettünk volna egy Youtube videót ágyazni az egyik Joomla cikkünkbe, vagy el akartunk helyezni egy IFrame alapú Facebook közösségi modult, de ez sehogy sem sikerült. Ez azért van, mert alapértelmezettként a Joomlában be van kapcsolva egy szövegszűrő funkció, ami az oldal biztonsága érdekében az összes csoportban tiltja a következő típusú tartalmakat: applet, body, bgsound, base, basefont, embed, frame, frameset, head, html, id, iframe, ilayer, layer, link, meta, name, object, script, style, title, xml.

Ezt kell nekünk kikapcsolnunk a Szuper felhasználók csoportjában a következő módon:

1. Lépjünk be az Adminisztrációs felületen a Webhely -> Globális konfiguráció -> Szövegszűrők beállításaihoz.

2. Keressük meg a Super Users csoportot és a szűrő típusát állítsuk, Nincs szűrés opcióra.  

Teszt:

0
0
0
s2sdefault
Log in to comment

BlackHeart profilkép
BlackHeart válaszolt a témára: #2 2015 márc. 12 15:39
Sziasztok!
Szeretnék youtube videót beágyazni egy cikkbe, de valamiért nem sikerül. Ezt a leírást találtam. A szövegszűrők beállításai a super user esetén alapból nincsre van állítva.
Néztem a szerkesztő beállításainál is itt is le volt tiltva az iframe. Próbáltam, hogy kivettem a tiltott elemek közül. Próbáltam, hogy az engedélyezettek közé betettem de továbbra sem engedi beágyazni a videót.
Van valami ötletetek mi lehet a gond?

Előre is köszönöm!
kocsislaci profilkép
kocsislaci válaszolt a témára: #3 2015 márc. 12 15:52
Szia!

Pontosan mi a hiba? Mit takar az, hogy nem engedi beágyazni? Nekem alap beállításakon simán engedi beágyazni a videó alatt lévő kóddal!
Ha leírod pontosan a hibát jobban tudunk segíteni!

Szia!
Balázs profilkép
Balázs válaszolt a témára: #4 2015 márc. 12 15:53
Igen, egy kis pontosítás nem ártana. Pl. Joomla!, szerkesztő verziója, vagy mit történik a kóddal, szerkesztő nélkül működik-e a beillesztés stb.
BlackHeart profilkép
BlackHeart válaszolt a témára: #5 2015 márc. 12 15:54
Igazából az, hogy nem történik semmi. A szerkesztőt átváltom a forráskód nézetre a cikk végére beillesztem az iframe-t. Leokézom és semmi nincs ott a videó.
Joomla 3.36. Szerkesztő: TinyMCE 4.1.2
Balázs profilkép
Balázs válaszolt a témára: #6 2015 márc. 12 15:57
Szerkesztő nélkül sem működik? Amúgy ebbe a cikkbe, teszt jelleggel beágyaztam egy cikket, tehát nem globális a probléma, mint ahogy Laci is jelezte.
kocsislaci profilkép
kocsislaci válaszolt a témára: #7 2015 márc. 12 16:03
Nekem akkor csinált ilyet mikor a forráskód nézetbe beillesztem a kódot, majd visszaváltom a szerkesztőt és úgy mentem.... akkor a kód eltünik..... ha a forráskód nézetbe mentem és bezárom akkro a videó marad!!! Újraszerkesztésnél is ugyan ez a hiba, ha nem forráskód nézetben történi ka szerkesztése akkor a kód eltünik!
BlackHeart profilkép
BlackHeart válaszolt a témára: #8 2015 márc. 12 16:04
Én se hiszem hogy általános probléma lenne. Átváltottam az alapértelmezett JoomlaCK szerkesztővel simán beágyazza a videót.
Olyan mintha a TinyMCE szöveg szűrője túlműködne nálam, mert ha a tiltott elemek közül kiveszem az iframet. És úgy kezdem szerkeszteni a cikket akkor az összes formázás eltűnik.
kocsislaci profilkép
kocsislaci válaszolt a témára: #9 2015 márc. 12 18:32
Én kizárólag JCE szerkesztőt használok. Többet kipróbáltam de ez maradt, bár mindig vágyok valami pluszra ami ebben nincs, de mésban van.....
freepetya profilkép
freepetya válaszolt a témára: #10 2015 márc. 13 08:35
Az alap TinyMCE szerkesztő beállításainál csak a tiltott elemekből kell törölni az iframe-t. Nem kell beírni sem az érvényes, sem a kibővített érvényes elemekhez.