Joomla kiadás - http://joomlabs.hu

Megjelent a Joomla! 3.3.4-es kiadása, amely számos hibajavításon felül 2 darab közepes szintű biztonsági problémát orvosol.

A hivatalos bejelentés megtekinthető a Joomla! kiadási oldalán. Az új csomagok a Letöltések menüpontból érhetők el. A magyar lokalizációt a belső nyelvtelepítő segítségével lehet feltelepíteni, míg az aktuális nyelvi fájl frissítését és a Joomla! új kiadását a belső bővítményfrissítőn keresztül.

0
0
0
s2sdefault
Log in to comment

Petronella profilkép
Petronella válaszolt a témára: #2 2014 szept. 25 00:58
Úgy bugos ahogy van.
Save & new és a save as copy gombok eltűntek a cikk szerkesztőben.
Balázs profilkép
Balázs válaszolt a témára: #3 2014 szept. 25 11:41
Ellenőriztem, nálam megvannak:

Zotius profilkép
Zotius válaszolt a témára: #4 2014 szept. 25 17:54

Petronella írta: Úgy bugos ahogy van.
Save & new és a save as copy gombok eltűntek a cikk szerkesztőben.

Akkor Nálad valami más, nagy gubanc lehet... Ez nem a J.3.3.4 hibája. Nálam is minden rendben van a frissítés után.
kisgal profilkép
kisgal válaszolt a témára: #5 2014 szept. 26 08:34
Sziasztok!

A jelenségre én is figyelmes lettem, de ez lehet már volt korábban is csak nem tűnt fel.

Tehát, ha egy új cikket szeretnék írni, akkor megjelenik a gombok között a "hiányzó" funkció. Azonban, ha már egy megírt cikket szerkesztek akkor nem látom én se. Ez lehet így jó is :)

Erre gondoltál?
Balázs profilkép
Balázs válaszolt a témára: #6 2014 szept. 26 11:19
Ezt megerősítem én is, meglévő cikk esetén tényleg hiányoznak a felsorolt funkciók.
Zotius profilkép
Zotius válaszolt a témára: #7 2014 szept. 26 11:24
Valóban, meglévő cikk újraszerkesztésekor más a helyzet.

(De talán, mintha ez már korábban is így lett volna. Nem emlékszem már rá)
Balázs profilkép
Balázs válaszolt a témára: #8 2014 szept. 26 12:07
Ránéztem egy régebbi verzióra (3.2.4) és ott még megvoltak ezek a funkciók.
freepetya profilkép
freepetya válaszolt a témára: #9 2014 szept. 26 15:15
Ha számít valamit a 3.3.3 verzióban nekem megvannak a hiányolt gombok, bár nálam nincs bekapcsolva a cikkeknél a verziók tárolása. Lehet, hogy ezzel a funkcióval összefügghet a dolog?
Balázs profilkép
Balázs válaszolt a témára: #10 2014 szept. 26 15:23
Verziókövetéstől függetlenül:

3.3.3 - Még meg vannak a gombok.
3.3.4 - Nincsenek meg a gombok.
Petronella profilkép
Petronella válaszolt a témára: #11 2014 szept. 26 21:48
Hiba leírása itt is,
github.com/joomla/joomla-cms/issues/4328

és a javítás alul, az egyik hozzászólásban.
vagy itt
github.com/joomla/joomla-cms/pull/4331/files


szerk:. Én sokszor meglévő cikknél használom ezeket a funkciókat, ott tartom leginkább használhatónak. Nekem ezért egyből feltűnt a probléma.
Balázs profilkép
Balázs válaszolt a témára: #12 2014 szept. 26 21:55
Köszi az utánjárást!
Zotius profilkép
Zotius válaszolt a témára: #13 2014 szept. 27 11:41
Köszi Petronella! A megadott linken leírtak szerint sikerült is a javítás. :D
Mások okulására ide teszem a linken látható javítást:
A libraries/cms/helper/content.php 124. sorában
erről:
$actions = JAccess::getActionsFromFile($path, "/access/section[@name='" . $section . "']/");
erre:
$actions = JAccess::getActionsFromFile($path, "/access/section[@name='component']/");
kell javítani. Tehát a sor végén az értékadásnál a " . $section . " kódrészlet cserélendő component-re
Végülis ennyi az egész...
Balázs profilkép
Balázs válaszolt a témára: #14 2014 szept. 27 12:11
Jó párszor volt már ilyen, hogy úgy vettek át javításokat/fejlesztéseket Gitről, hogy ellőtte nem tesztelték le rendesen.
Petronella profilkép
Petronella válaszolt a témára: #15 2014 szept. 30 07:16
Még valamibe beleütköztem és nem tudom ez mikori hiba, és csak nálam jelentkezik-e.

A Media managerben nem tudok képet feltölteni.
A hiba, ha kiválasztom tallózással a képet és a feltöltésre (Start upload) nyomok akkor a "Cím nem található" szürke FF oldal jön be és a címsorba a "undefined://index.phpundefinedundefined?option=com_media&task=file.upload&tmpl=component&.............."
URL jelenik meg.
Megnézné más is, hogy vajon csak nekem ilyen? Köszönöm
Balázs profilkép
Balázs válaszolt a témára: #16 2014 szept. 30 09:18
Nálam működik a Médiakezelő, én egyébként mindig JoomlaCK Editort használok, annak meg van saját feltöltője.
Petronella profilkép
Petronella válaszolt a témára: #17 2014 szept. 30 22:07
Én is JCE-t, de bizonyos esetekben nem használható. A menu managerben új menüelem létrehozásakor, ha szeretnék a menühöz logo ikont társítani, akkor azt a "Link type" lapfülnél tudom megadni és ott csak a media manager van.
Most ideiglenesen feltöltöttem a JCE-vel a cikk kezelőn keresztül és a menu managerben pedig betallóztam.

Amúgy megjelent a Joomla! 3.3.5 verzió, de nálam a backend még nem értesít róla.
Balázs profilkép
Balázs válaszolt a témára: #18 2014 szept. 30 23:03
Lehet, hogy ezt most nem akarják elkapkodni, mint az előző kiadást.
Petronella profilkép
Petronella válaszolt a témára: #19 2014 okt. 01 01:12
Lehet a copy&save bugot pont a JCE okozza, valami hasonlót posztoltak a linkelt github topikban.
Balázs profilkép
Balázs válaszolt a témára: #20 2014 okt. 01 10:40
Előtte meg azt írták, hogy olyan bővítmények esetén, melyek a Joomla! alapértelmezett kategóriakezelőjét használják pl. Phoca Guestbook, szintén eltűntek a gombok. Egyébként azt eltudom képzelni, hogy a tesztelés, csak addig történt, hogy a rendszerkomponenseknél minden rendben, valamint a TinyMCE-vel.