Gantry 5 rendszerkövetelmények és előzetes információk - Joomla! Magyarország

A RocketTheme csapata jelenleg is gőzerővel dolgozik azon, hogy mihamarabb kiadásra kerüljön a Gantry 5-ös kiadása, amely az eddigi legnagyobb és legjelentősebb frissítés lesz a 2009 óta jelen levő Joomla! keretrendszer életében.

Egyelőre még nincs bejelentett megjelenési dátum, de a fejlesztők addig is, néhány népszerű kérdésre megosztották a választ.

Mi lesz a Gantry 5 alapvető rendszerkövetelménye?

A Gantry 5 készítésekor fő szempont volt az előremutató szemlélet alkalmazása, amelynek következménye a követelmények szigorodása, amelyek a következők:

  • Jommla! 3.4+
  • PHP 5.4+
  • Legfrissebb verziójú Chrome/Opera/Safari/Opera, limitált IE9 kompatibilitás, valamint IE10 vagy e feletti verziójú böngészők támogatottak.

Gantry 5 teljesen kifogja használni a Joomla! által nyújtott funkciókat. A megkövetelt 5.4-es verziójú PHP megléte, tisztább kódbázist tesz lehetővé, amellyel egyszerűbb dolgozni, valamint gyorsabb lefutást biztosít, a régebbi verziók kompatibilitásának megtartásával. Gyakorlatilag már minden tárhelyszolgáltató támogatja az új verziót, mivel az 5.3 támogatási ideje ez év júliusában jár le.

Kompatibilis lesz-e visszafelé a Gantry 5?

A rövid válasz a kérdésre az, hogy nem. A Gantry 5 keretrendszer egy alapjaiból átírt rendszer lesz, így nem lesz kompatibilist a régebbi verziókkal. A Gantry új kiadása még könnyebben használható, letisztult kiadás lesz, egy egész sornyi új eszközzel és funkcióval, amelyeket már nem lehetett beleintegrálni a mostani keretrendszerbe.

Mit várhatunk az új kiadástól?

A Gantry 5 lesz a leggyorsabb és legmegbízhatóbb változata a keretrendszernek. Az új rendszer az alapoktól lesz teljesen újjáépítve. A fejlesztők fontosnak tartják a modern webes szabványok alkalmazását, evvel is utat engedve a jövőbeli technológiáknak.

Az új rendszer fejlesztésekor figyelembe veszik a közösség által megfogalmazott visszajelzéseket, és ez alapján még egyszerűbbé teszik az adminisztrálást, amennyire csak lehetséges, hogy olyan felhasználók is könnyedén tudják kezelni a rendszert, akik előtte sosem használtak webes megoldásokat. Fontos hangsúlyt kapott még a sebesség növelése, így a visszafelé kompatibilitást (a régi kódbázist) elvetve, valamint a PHP 5.4-es verzióját felhasználva az elődeinél még gyorsabb rendszer fogunk készhez kapni.

Megszűnik-e a Gantry 4 és az ehhez kapcsolód termékek támogatása?

Nem, a RocketTheme párhuzamosan fogja támogatni mind a két verziót. A jövőben együttesen lesz elérhető Gantry 4-el és 5-el kompatibilis változatok az egyes sablonokból és bővítményekből.

Változik-e a Gantry 5 licencelése az előző verziókhoz képest?

Nem változik, a Gantry Framework továbbra is GPL licenc alatt kerül kiadásra.

Ti milyen funkciókat látnátok szívesen az új verzióban?

0
0
0
s2sdefault
Log in to comment

Petronella profilkép
Petronella válaszolt a témára: #2 2014 júl. 25 22:02
Öröm, hogy lehet majd újraépíteni az oldalt :)
Ezek szerint a J3.4 és J3.5 között fog kijönni? magyarul 2014 szeptember előtt?
Balázs profilkép
Balázs válaszolt a témára: #3 2014 júl. 26 13:11
A 4-es széria párhuzamosan lesz támogatva az új verzióval. A fejlesztők egyenlőre még pontos dátumot nem jelentettek be. Az új keretrendszer minimumja a Joomla! 3.4 megléte, amely nem azt jelenti, hogy akkor is fog megjelenni. Ez még csak egy nagyon előzetes bejelentés volt.