Ha-ha-ha! :) Ezt nézzétek meg!

  • McGregor
  • McGregor profilkép
  • Nem elérhető
  • Kezdő fórumozó
  • Kezdő fórumozó
  • I love the smell of napalm in the morning
Több
6 éve 7 hónapja #12775 Írta: McGregor
McGregor válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
Sziasztok, próbálgatom én is az ssl beállítását az oldalamon. Google font-okat használ a sablon, de ssl esetén nem jeleníti meg őket. Valakinek ötlete van erre?

A csapatmunka roppant fontos: rajtad kívül másra is lőhetnek!

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
6 éve 7 hónapja #12782 Írta: kovacshazi
kovacshazi válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
A fontok meghívásánál nézd meg a google-ra hivatkozó linket.
https legyen az is, illetve tulajdonképpen már egy ideje nem kell "http:" és a "https:" elég csak a a dupla y/-től kezdődően azaz "//linkkezdete.com"

Segítség Joomla és VirtueMart webáruház készítéséhez, problémák megoldásában
www.webprogramok.hu

Joomladay2013 - Budapest, Hungary
www.joomladay.hu
A következő felhasználók mondtak köszönetet: Balázs, McGregor

Jelentkezz be, hogy te is részt vehess beszélgetésben!

  • McGregor
  • McGregor profilkép
  • Nem elérhető
  • Kezdő fórumozó
  • Kezdő fórumozó
  • I love the smell of napalm in the morning
Több
6 éve 6 hónapja #12792 Írta: McGregor
McGregor válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
Óóó, hogyaza :D Gondoltam rá, de nem hittem, hogy ez a baj :) 1000köszönet. Szuper!

A csapatmunka roppant fontos: rajtad kívül másra is lőhetnek!

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
5 éve 3 hónapja #14511 Írta: kamant
kamant válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
Sziasztok!

Most állítottam át egy régebbi oldalamat https-re. Szépen meg is jelennek az oldalak https-sel beírva (ill. a Chrome is automatikusan úgy hozza már protokoll nélkül beírva).
Szeretném megcsinálni, hogy a http-s hivatkozások is álljanak át automatikusan, viszont, ha átírom a .htaccess-t az itt is megadott kiegészítésekkel, akkor az "Oldal nem található" hibát kapom. Az oldal többnyelvű lesz, egyelőre a magyar változat megy (domainom.hu/hu/... formában jelennek meg az oldalak címei, itt nem tetszik neki valami.

Az ötleteket előre is köszönöm.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
5 éve 3 hónapja #14512 Írta: kovacshazi
kovacshazi válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
Nehéz látatlanban segítséget nyújtani. Mondanám vak vezet világtalant, de ez a mondás igazából másra vonatkozik :).
A lényeg. Kérdés egyáltalán engedélyezett-e a szerveren a .htaccess használata, ha az igen akkor engedélyezett-e a mod_rewrite?
Ha mindezek igen, akkor az a kérdés mit írtál a .htaccess-be?

Segítség Joomla és VirtueMart webáruház készítéséhez, problémák megoldásában
www.webprogramok.hu

Joomladay2013 - Budapest, Hungary
www.joomladay.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
5 éve 3 hónapja #14518 Írta: kamant
kamant válaszolt a következő témában: SSL-protokoll használata Joomla! alatt
Bocsánat, az lemaradt, hogy ugyanezen a tárhelyen, ugyanilyen beállításokkal egy másik domainen levő szintén joomlas, de nem többnyelvű oldal szépen csinálja a http-https átirányítást.

Ezt tettem a htaccessbe:
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Ezen felül a kiszolgáló beállításaiban is kértem a teljes webhelyre a https-kényszerítést.

Igen, nehéz látatlanban, tudom. :) És köszönöm a segítő szándékot!

Jelentkezz be, hogy te is részt vehess beszélgetésben!