file A Joomla! 4 és a Gantry 5 kompatibilitása

Több
2021 aug. 27 19:31 #1 Írta: Zotius
A Joomla! 4 és a Gantry 5 kompatibilitása téma létrehozva Zotius által
Teszt jelleggel egy aldomainemen telepítettem a szűz J4.0.2-t. A "Cassiopeia" sablon nem egy nagy durranás, ezért megkíséreltem rátenni a Gantry legutóbbi, 5.4.37 verzióját.
Bár ne tettem volna... :( a backend és frontend is teljesen összeomlott, 500-as hibával. Megoldásként töröltem az összes gantry5-höz tartozó mappát, kitakarítottam az adatbázist, töröltem a configuration.php-t, újra felraktam a telepítő mappát, szóval a kályhától indultam ismét. Régi oldalaim frissítését J4-re a Ganty 5 miatt már nem is merem elkezdeni.
Meginogott a bizalmam... Mi van, ha később bármilyen telepítésre kerülő bővítményről kiderül, hogy inkompatibilis a Joomla 4-el? Újabb összeomlás, újabb szívások sorozata következik?
Egyébként véleményem első látásra:
A backend-et nagyon átszervezték, alig találom meg amit keresek. Az nem egetrengető fejlesztés, hogy a felső menüt átrakták a baloldalra. Abból pedig, hogy a háttérben mi változott, egyelőre nem sok érzékelhető.

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2021 aug. 28 09:50 #2 Írta: Zotius
Zotius válaszolt a következő témában: Megérkezett a Joomla! 4.0.2 hibajavítás
A rockettheme.com fórum közleményei között olvastam:
"Gantry 5 and it's templates
For the past few months our team have been busy working on the developments necessary to make Gantry 5 compatible with Joomla 4. We could not finalise this work until the official release of Joomla 4. The release of Gantry 5 that will work with Joomla 4 will be known as Gantry 5.5."

Szóval, dolgoznak a kompatibilitás megteremtésén, az új verzió a Gantry 5.5 lesz. Biztató.

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2021 aug. 29 06:55 #3 Írta: Balázs
Balázs válaszolt a következő témában: A Joomla! 4 és a Gantry 5 kompatibilitása
Sok jó hírrel nem szolgálhatok. A Gantry ott tart kb., amikor 6 éve megjelent. A GitHub repo alapján készül egy 5.5-ös verzió, de ott annyi infó van, hogy "Joomla 3.9 minimum with limited Joomla 4.0 compatibility", amely szerintem nem jelenthet valami túl sok jót. Lehet, hogy érdemes lehet megfontolni a JoomlArt T4 Framework-re való áttérést, amely Joomla 4 kompatibilis (Bootstrap 4 támogatással).

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2021 aug. 29 10:47 #4 Írta: Zotius
Zotius válaszolt a következő témában: A Joomla! 4 és a Gantry 5 kompatibilitása
Rendben, kipróbálom a T4 Framework-öt a teszt oldalamon. Kíváncsi vagyok, nyújt-e olyan lehetőségeket, mint a Gantry.
Az elkeserítő azonban, hogy amit anno a Gantry bevezetésével megteremtettek – a template-ek alakításának szinte teljes szabadságát, és ezzel sok felhasználót csábítottak magukhoz – most egyszerűen megy a kukába? Lehet, hogy kissé konzervatív vagyok, de szerintem az nem túl nagy baj, hogy – mint írod – a Gantry ott tart, ahol kb 6 éve... Ami kell, az benne van.

Ha hasznos volt a hozzászólásom számodra, nyugodtan megnyomhatod lent a „Köszönet” gombot :)
Skype: zotius

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 márc. 29 10:26 #5 Írta: labor
labor válaszolt a következő témában: A Joomla! 4 és a Gantry 5 kompatibilitása
Üdv!
Úgy látom a Gantry már az 5.5.11-nél jár, van valakinek tapasztalata hogyan működik Joomla 4 alatt?

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 márc. 31 08:59 #6 Írta: csicsa55
csicsa55 válaszolt a következő témában: A Joomla! 4 és a Gantry 5 kompatibilitása
Már egy fél éve joomla4 kompatibilis a gantry 5. Pont most csinálok egy új oldalt joomla4-gyel és gantryval. Az inspire theme által kínált ingyenes atomok jelentős részét is j4 kompatibilissé tették.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2022 márc. 31 10:31 - 2022 márc. 31 10:32 #7 Írta: csicsa55
csicsa55 válaszolt a következő témában: A Joomla! 4 és a Gantry 5 kompatibilitása
Eddigi tapasztalataim szerint megnyugodhatunk. Amikor kijött az 5.5.0-ás gantry, amiben újítás a j4 kompatibilitás, ott még több j3-as oldalam frontendje fejre állt az 5.4.37->5.5.0 upgradetől, ami azért is baj, mert simán felajánlotta a frissítéskezelő, én meg rányomtam. Azóta csak jót tudok mondani a gantryról.
A tudástárban ismertetett leírások is jók j4-hez, csak érdemes lenne a cikk elejére odabiggyeszteni, hogy j4-nél ne a leírásba tett közvetlen linkről szedjük le az inspire theme kiegészítőit, hanem a honlapjukról a letöltési szekcióból.
Utolsó szerkesztés: 2022 márc. 31 10:32 csicsa55 által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!