Gantry - 5.3.0-ra való frissítés után az adminban "Can't use method return value in write context" hiba

Több
7 éve 9 hónapja #9944 Írta: Mirian
Üdv!

Nagy boldogságomra megérkezett az új Gantry, így már ma reggel frissítési üzenetként is ott várt az admin panelben.
Mind a Gantry-t, mind pedig az alapértelmezettnek beállított Hydrogen-t frissítettem. Szépen ment is, sorba jött a Frissítés sikeres üzenet...
Belépve a Sablonokhoz viszont, már a Hydrogen-ra kattintva egy nem várt üzenet fogadott:




Nem vagyok sajnos még nagy joomla-mágus, így írtam a tárhelyszolgáltatónak, hogy hátha a PHP-t kellene frissíteni, mert ilyesmit írt ki a Google, erre ők visszaírtak, hogy frissítették PHP 5.3-ra.
Majd az imént látom ám a Joomla Magyarország fb oldalán, hogy PHP 5.6 alatt ne is reméljek semmit. Most várom a válaszukat, mert kértem őket, hogy frissítsenek még egyet, de vajon tényleg ez lenne a hiba?

Ha valaki tud, kérem segítsetek! Köszi előre is! :(
Mellékletek:

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
7 éve 9 hónapja #9945 Írta: Balázs
Igen, az 5.3.0-ás Gantry verzió jelenleg, csak PHP 5.6 feletti verziószámmal működik. Az 5.3.1-ben még lesz egy javítás, amely segítségével el fog futni PHP 5.4-en, de ezt a verziót már nem igazán szeretnék támogatni, mivel 1 éve már nem támogatott csak az 5.6-os és a 7-es vonal.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
A következő felhasználók mondtak köszönetet: Mirian

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
7 éve 9 hónapja - 7 éve 9 hónapja #9946 Írta: Mirian
Köszi szépen itt is! Nincs mit tennem, akkor most türelmesen várom, hogy a tárhelyszolgáltató visszaírjon.
Most csak reménykedem, hogy azzal megoldódik a gond.

Egyelőre ezt írták vissza: "Ez program hiba. Arról szól, hogy a megjelölt sornál nem használhatja visszatérési értéknek a most használt metódust."

:blink: ...jó lenne tudni, hogy akkor most mi a helyzet.
Utolsó szerkesztés: 7 éve 9 hónapja Mirian által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
7 éve 9 hónapja #9947 Írta: csezo
program hiba, hiszen a régebbi PHP verziók valamit nem úgy csinálnak, ahogy szeretnéd. De a megoldás a program követelményeinek megfelelő verzióra váltás lesz
Én három oldalamat frissítettem ma , és 5.6.22 PHP-vel korrekten fut

Ha értékesnek találtad a hozzászólást, azt a "KÖSZÖNÖM" gombbal jelezheted.
A következő felhasználók mondtak köszönetet: Mirian

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
7 éve 9 hónapja #9948 Írta: Mirian

csezo írta: program hiba, hiszen a régebbi PHP verziók valamit nem úgy csinálnak, ahogy szeretnéd. De a megoldás a program követelményeinek megfelelő verzióra váltás lesz
Én három oldalamat frissítettem ma , és 5.6.22 PHP-vel korrekten fut


Köszi szépen! Ez jó hír.
Akkor még próbálom kérlelni a tárhelyszolgáltatót. Eddig egyszer fordultam hozzájuk, de korrektek voltak, türelmes leszek. :unsure:

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
7 éve 9 hónapja - 7 éve 9 hónapja #9952 Írta: Mirian
:cheer: :) Minden megoldódott. 5.5-re lett frissítve a PHP és simán rendbe jött a hozzáférhetőség, adminisztrációs felület elérhető a sablonoknál. :)
A tárhelyszolgáltató munkatársa erre az oldalra hivatkozott, ahol elégnek írják az 5.5-öt.
stackoverflow.com/questions/1075534/cant...lue-in-write-context
Köszönöm szépen figyelmeteket és a segítséget szintén! :)
Utolsó szerkesztés: 7 éve 9 hónapja Mirian által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!