Megérkezett a Joomla! 5.0 és a Joomla! 4.4

Több
8 hónapja 2 hete - 8 hónapja 2 hete #17582 Írta: Balázs
Balázs válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
Igazából a jóság az elég szubjektív. Ami egyértelműnek látszik, hogy csak az a framework tud fejlődni, ami mögött van megfelelő bevétel, amelyből ki lehet fizetni a fejlesztőket. A Gantry 5-öt megcsinálták 8 éve, azóta gyakorlatilag csak reszelés van. Az erőforrásokat a Grav CMS-re tették, közben a RocketTheme is nullázódott, 1.5 éve új sablon sincs, a fejlesztők pedig elpárologtak. Én most átrakom az egészet próbaképpen T4-re, aztán kiderül. Ami mögött van pénz a YooThemes sitebuildere, ami ugyan fizetős, de ezt folyamatosan fejlesztik, folyamatosan új építőelemek kerülnek be, a nagyobb csomagban pedig még több. Én, akikkel kapcsolatban vagyok Joomla! fejlesztőkkel, azok már csak YooTheme sitebuilder + VMuikit kombóval építenek pl. VM-es webáruházakat. Egyébként a Helix is jól frissül, jelenleg már natívan támogatja a Joomla 5-öt és a PHP 8.2-t, ellenben a T4-gyel, amely nem, a Gantry-ről meg már nem is beszélve.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 8 hónapja 2 hete Balázs által.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
8 hónapja 1 hete #17583 Írta: csezo
csezo válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
Egy ideje a Helix Ultimate -et használom, számomra maradéktalanul bevált. A Gantry után egy felüdülés a különböző eszközökre való megjelenés beállítása.
A T4 is jó volt.. de nekem a Helix jobban "fekszik"

Ha értékesnek találtad a hozzászólást, azt a "KÖSZÖNÖM" gombbal jelezheted.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
8 hónapja 1 hete #17586 Írta: kovacshazi
kovacshazi válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
Érdekes ez a keretrendszer használat, meg a különböző PageBuilderek használata. Látom, hogy a WordPress és a Joomnla is ebbe az irányba halad, pedig a Joomla egyik erőssége szerintem pont a modulok elég jó variálhatósága és a könnyű sablon felülírás.
Emiatt ha lehet épp ezért inkább egyedi sablonokat készítek. Nem hiszem, hogy a felhasználó szereti megtanulni a Page Builderek használatát. Ráadásul azok szinte mind fizetősek, így ha a frissítés lehetőségét meg akarják tartani akkor évente biztosan ki kell fizetni ere is 50-70-100USD-t.
Ráadásul a keretrendszerek és Page Builderek szerintem erősen megnehezítik az egyedi grafikára készült oldal elkészítését, amikor a grafikus nem a szokásos 30-60-90 stb paddingekkel, margókkal dolgozik.
Ilyenkor lehet megerőszakolni !important és egyéb megoldásokkal a keretrendszerek és PB saját css-eket, ami lássuk be oladl betöltés szempontjából nem túl jó.
Arról nem is beszélve, hogy a keretrendszerek és PB css fájljai sokszor több tízezer sor, sokszor mellé töltve a Bootstrap vagy hasonló css-t, valamint ehhez még jönnek a telepített kiegészítők css és js fájljai. Rengeteg! Most tényleg kell ez?

Itt egy oldal egyedi sablonnal: www.polynova.com/
A sablon saját css-e nincs 1000 sor, nincs benne felesleges JS, csak ami tényleg kell.
Sajnos itt is vannak telepített kiegészítők, de csak azok amik tényleg kellenek.
Ennyit a saját sablon mellett.

Ha már keretrendszer akkor a JoomShapert látom életerősnek.

Csak csendben jegyzem meg, hogy egy másik oldalon szintén saját sablonnal abszolút simán ment a J5-re frissítés. Nem tudom ez a keretrendszerekkel vajon megy-e?

Segítség Joomla és VirtueMart webáruház készítéséhez, problémák megoldásában
www.webprogramok.hu

Joomladay2013 - Budapest, Hungary
www.joomladay.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
8 hónapja 1 hete #17587 Írta: csicsa55
csicsa55 válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
A keretrendszerek ingyenesek. A Joomshaperé is ugyanúgy, mint gantry vagy T4. 

A rájuk épülő sablonok már nem. Meg a builderek sem ez igaz. Én szigorúan csak keretrendszer használok, nem szoktam page buildereket venni. Hanem css felülírással teszek hozzá dolgokat vagy javítok. Egyik érv, amiért ezt használom, mert joomla frissítéssel nem kell újraírni/módosítani semmit. Persze ez a lehetőség gantrynál most megszűnt. Azt nem tudtam, hogy a joomla 4-re írt egyedi sablon működik joomla 5-tel is. Ez új.
Ha valamilyen okból kifolyólag elvétve sablont vásárolok az nem épül egyik keretrendszerre sem.

A pagebuilderekkel nekem egyetlen bajom van csak. A begépelt szöveg nem egy bele az adatbázisbaí így egy sabloncserénél oda a kontent, valamint a joomla sem tudja kategorizálni/szűrni.

Az pedig, hogy az ilyen agyontömött meg bonyolított rendszerekkel ellátott honlapok lassabban töltődnek be egy darabig nem zavaró.

Mutatok én olyan oldalt, ha kell, ami nem cmsre épült és borzalmas, lassabban töltődik be, mint bátmelyik gantrys joomla oldalam.

Tessék:  savariamuseum.hu/

Az a véleményem, a legtöbb megrendelőt egy bizonyos szintig nem érdekli a betöltési sebesség. Persze, ha már látványosan lassú, mint a linkelt oldal, akkor már igen.

Arra kiváncsi lennék kovacshazi mennyit kérsz egy sablon megírásáért, mert nem biztos, hogy jobban megéri az ügyfélnek, mint megvenni egy kész (nem keretrendszerre épülő) sablont.

De ha már előkerült a téma, meghallgatnám az ellenérveket Balázstól, hogy Ő miért használ keretrendszert egyedi sablon helyett.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
8 hónapja 1 hete #17588 Írta: csicsa55
csicsa55 válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
Itt temetjük a gantryt, aztán tegnap is kijött egy frissítés. A leírás szerint már alavető joomla5 támogatás is van. A remény hal meg utoljára. Ennek örülök, mert a joomleadtól egy rakás atomot meg részecskét megvettem. Megépítem belőle a joomlatombobmbát. Na akkor ez a probléma pipa. Nyitok egy másik szálat egy sokkal sürgetőbbnek.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
8 hónapja 1 hete #17593 Írta: csicsa55
csicsa55 válaszolt a következő témában: Megérkezett a Joomla! 5.0 és a Joomla! 4.4
Ha már a gantryt emlegetjük azért szerintem kár volt levenni a manualját az oldalról. Maximum érdemes megjelölni, hogy figyelem, támogatása kétséges. Használata csak saját felelősségre.

Jelentkezz be, hogy te is részt vehess beszélgetésben!