Kérdés NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé

Több
2016 okt. 30 00:09 #1 Írta: freepetya
freepetya létrehozta a témát: NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé
Szeretnék segítséget kérni. Egy Joomla 2.5->3 sikeres frissítése után az eddig használt sablont kellene működésre bírni. A sablon innen letölthető:
www.joomlaos.de/option,com_remository/It...ileinfo/id,6847.html

Az admin felületen a sablon paramétereiben volt hiba a betöltődéssel, erre találtam megoldást.
A templates/nld_101_16/admin/loader.php fájlban a javítás.

replace:
$header_media = $document->addStyleSheet(JURI::root(1) . '/templates/nld_101_16/css/admin.css');
$header_media .= $document->addScript(JURI::root(1) . '/templates/nld_101_16/js/jscolor.js');

with
$document->addStyleSheet(JURI::root(1) . '/templates/nld_101_16/css/admin.css');
$document->addScript(JURI::root(1) . '/templates/nld_101_16/js/jscolor.js');

Go to joomla global configuration and level down "Error Reporting" parameter

Így az admin felület látszólag ok. A frontenden olyan mintha nem töltődne be a css. A templates/nld_101_16/css/ mappában van egy template.css.php fájl ami szerintem nem hajtódik végre, ennek keresném az okát.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2016 okt. 30 02:35 #2 Írta: Balázs
Balázs válaszolt a témára: NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé
Mondjuk itt már erősen a 2.5-ös kompatibilitás is kérdéses, hiszen a támogatott verzióknál a Joomla! 1.7 és az 1.6 szerepel. Kérdés, hogy találtál-e arra vonatkozó sort, ami behúzná a kérdéses fájlt?

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2016 okt. 30 08:46 #3 Írta: freepetya
freepetya válaszolt a témára: NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé
A 2.5-ös oldalon megy hiba nélkül. A sablon index.php -ben benne van ez:
<?php include_once ('wrapper/inc_head.php'); ?>

Az inc_head.php -ben pedig ezek:
<link rel="stylesheet" href="templates/system/css/system.css" type="text/css" />
<link rel="stylesheet" href="templates/nld_101_16/css/template.css.php" type="text/css" />
<link rel="stylesheet" href="templates/nld_101_16/css/override_template.css" type="text/css" />

A forráskódban is látszik. A template.css.php fájlban az elején lévő php kód és az utána lévő css elemek nem érvényesülnek. Mindenképpen valami joomla kompatibilitási problémára gondolok, csak nem tudom konkrétan mi lehet.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2016 okt. 30 15:17 #4 Írta: csezo
csezo válaszolt a témára: NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé
nem fogsz neki örülni, de..... szerintem hagyd a francba. Inkább állítsd be a gantry ban az adott nevű modulokat, és húzd rá a formázást.
Az a sablon szinte kizárt, hogy tudná a mai elvárásokat, mobil nézet, responziv kialakítás, stb

Ha értékesnek találtad a hozzászólást, azt a "KÖSZÖNÖM" gombbal jelezheted.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2016 okt. 31 07:39 #5 Írta: freepetya
freepetya válaszolt a témára: NLD 101 sablon régi verziójának átalakítása 3.6 kompatibilissé
Igen, ez világos, valóban a sablon nem mai darab, de alapvetően a jooomla frissítése lett volna a feladat. Még rímel is. :)

Jelentkezz be, hogy te is részt vehess beszélgetésben!