Kérdés PHP frissítés után Deprecated: preg_replace() hiba

Több
2017 márc. 11 00:05 #1 Írta: MoZo
MoZo létrehozta a témát: PHP frissítés után Deprecated: preg_replace() hiba
Sziasztok,

kérek szépen segítséget.

Miután frissítették a servert PHP nagyon alacsonyról 5,6-ra a weboldalba bekerült egy csomó elavult figyelmeztetés.Az icon problémáját megoldottam hosszas guglizás után, de ezzel nem boldogulok ezzel:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in 652
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in 654

note++ ban helyettesítettem callback - re, de ezután ez jött ki ismételve:

Warning: preg_replace_callback(): Requires argument 2, 'utf8_encode(chr(\1))
Warning: preg_replace_callback(): Requires argument 2, 'utf8_encode(chr(0x\1))',

mit kell átírnom?

Előre is köszi

Ja, nem vagyok programozó, kezdő JAVAzó csak

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 00:21 - 2017 márc. 11 00:22 #2 Írta: Balázs
Balázs válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
Itt inkább az a kérdés, hogy milyen Joomlát használsz. A Joomla! 3 feletti bővítményeknek általában nem szokott problémát okozni a PHP 5.6-os verziója.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2017 márc. 11 00:22 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 08:14 #3 Írta: MoZo
MoZo válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
Igen, alapvetően ezt szeretném megoldani.
Most kaptam kezelésre a felületet, Joomla 2.5.11 -es verzióval.

Telepítettem az akeeba beckup -ot, megcsináltam a mentést, de le már nem sikerült töltenem saját gépre.
Gyorsítótárat kitöröltem, de frissítés ikon nem jelenik meg.

Gondoltam a sok elavult jelzés feloldásával megoldódik a frissítés gomb. De nem.

Hát itt tartok.

Köszönöm a segítséged.

Alapvetően WP -t kezelek.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 08:55 - 2017 márc. 11 08:56 #4 Írta: Balázs
Balázs válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
Itt az alapvető probléma az, hogy a joomlában a 3.6-os verzióban járunk, és ezért a magasabb PHP miatt "sírni" fognak folyamatosan az elavult bővítmények, tehát mindenképpen frissítened kellene, minimum a 2-es verzió végéig (2.5.28).

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2017 márc. 11 08:56 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 09:12 #5 Írta: MoZo
MoZo válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
Igen ezen vagyok.

Csakhogy nincs frissítés ikonom.

Viszont a Bővítménykezelő > frissítésénél kiírja a két "Deprecated.." hibát , valamint, h nincs újabb frissítés:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /chroot/home/fittmami/moka-kert.hu/html/libraries/joomla/filter/input.php on line 652

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /chroot/home/fittmami/moka-kert.hu/html/libraries/joomla/filter/input.php on line 654

Pillanatnyilag egy frissítés sem érhető el. Kérjük, később ellenőrizze újra.

Ezért gondoltam megoldani elsőként azokat.

Szerinted mit kellene tennem?

Köszönöm

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 09:20 - 2017 márc. 11 09:33 #6 Írta: Balázs
Balázs válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
Amit elsőként meg lehet próbálni az-az, hogy a Globális konfigurációban ki kellene kapcsolni a Hibakiíratást. Most csatolok egy képet, de ez a 2-es szériában máshogy néz ki:

Aztán frissíteni kellene kézzel először 2.5.28-al úgy, hogy a legutolsó frissítőcsomagot könyvtárhelyesen felül kellene íratnod az FTP-n a jelenlegi struktúrával.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Mellékletek:
Utolsó szerkesztés: 2017 márc. 11 09:33 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 09:52 #7 Írta: MoZo
MoZo válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
köszönöm, hibajelentés kikapcsolva.

letöltöttem, ftp-n áthúztam a 28-as csomagot, de itt ücsörög.
Mellékletek:

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 10:46 - 2017 márc. 11 13:17 #8 Írta: MoZo
MoZo válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
sokáig töltött, mindig folytatni kellett, elvileg befejeződött, de az admin felületen nincs változás.

ezt kell orvosolni?

Mellékletek:
Utolsó szerkesztés: 2017 márc. 11 13:17 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 11:04 - 2017 márc. 11 11:08 #9 Írta: Balázs
Balázs válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
A fizikai fájlmásolás megtörtént akkor? A fopent pedig engedélyezned kell a hoszting beállításaiban, mert nem fog kilátni a rendszer a frissítő szerverekre.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2017 márc. 11 11:08 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 márc. 11 11:40 #10 Írta: MoZo
MoZo válaszolt a témára: PHP frissítés után Deprecated: preg_replace() hiba
hogy megtörtént-e? Én megcsináltam (FTP-n felment), de nincs megerősítő adat.

fopen engedélyezése nem servergazda teszi?

Én ez cPanelen be tudom állítani?

Köszi

Jelentkezz be, hogy te is részt vehess beszélgetésben!