Kérdés A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.

Több
2014 márc. 14 18:16 #1 Írta: lato78
lato78 létrehozta a témát: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
2.5.13-as Joomla oldal vezérlőpultban található frissítés ellenőrzője jelezte, hogy nem naprakész az oldal, van már megjelent frissítés. Ez még akkor a 2.5.14 volt. A frissítést akkor úgy végeztem el, hogy egy sima ftp kliens programmal felülírtam a tárhelyen lévő fájlokat a frissító csomagban található fájlokkal. Belépve az admin felületre továbbra is frissítésre szorulónak véli a belső frissítés ellenőrző az oldalt, pedig alul középen már a 2.5.14 verzió olvasható és az adatbázis javítás lefuttatása után már az addig meglévő adatbázis verzió eltérés is megszűnt.
Egyik kérdésem, hogy miképpen lehet megoldani, hogy ne a régi verziót olvassa ki a frissítés ellenőrző, egyáltalán honna olvassa be ezt az adatot? Kerestem, de nem találtam rá.
Másik kérdésem, hogy ha a belső frissítéskezelővel kívánom a frissítőcsomagokat telepíteni, akkor a "JFolder::create: Az elérési út nem open_basedir elérési utakon van" üzenettel már a telepítőcsomag letöltése sem sikerül a tárhelyen, de ugyanez a belső frissítési mód rendben megtörténik localhost-on. Hol keressem a probléma forrását, megoldását? Segítségeteket előre is köszönöm.
Mellékletek:

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 14 23:36 - 2014 márc. 14 23:36 #2 Írta: Balázs
Balázs válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
1. I am getting Error "JFolder::create: Path not in open_basedir paths Unable to create destination" while installing Joomla extension. How to solve?

2. SQL-ben van tárolva az adott verzió. Érdemes lenne, olyan frissítést telepítened a Bővítménykezelőn keresztül, amely teljes sorozatot frissít fel, pl. Joomla_2.5.x_to_2.5.19-Stable-Patch_Package.zip

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2014 márc. 14 23:36 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 16 09:25 #3 Írta: lato78
lato78 válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
Köszönöm a gyors választ. Sajnos azonban továbbra sem megy a dolog. És csak a tárhely esetén, localhoston ugyanis nincs probléma a frissítésekkel.
A linken küldött segédlet szerinti módosítást megcsináltam, az "open basedir" hibaüzenet helyett azonban másik jött elő. A mellékelt képen látszik. Az általad javasolt frissítést próbáltam a bővítménykezelőn keresztül feltenni. Mindhárom ott lévő lehetőséget kipróbáltam, az eredmény azonos.
Mintha jogosultság probléma lenne. Azt sem értem, hogy miért akar létrehozni "tmp" mappát, amikor már van, ráadásul írási jogot is adtam rá? Lehet az gond, hogy biztonsági okokból nem a tárhely gyökérkönyvtárába telepítettem a joomlát, hanem egy szinttel lejjebb? Azaz a " www.honlapom.hu/joomla " alatt vannak a joomla mappák, fájlok, így itt van pl. a "tmp" mappa is, itt van az "index.php", stb. A localhoston viszont a gyökérben van a telepítés, lehet, hogy ott azért működik? tárhelyen pedig nem találja a "tmp"-t?

A másik: Igen, néztem az sql-t, hogy vajon hol tárolja az adott verziót, de rákeresve nagyon sok helyen előfordulnak ezek a verziós számok, nem tudom pontosan melyik táblában, hol keressem. Ráadásul megcsináltam azt a lokális gépemen, hogy a lementett teljes sql szövegfájlban lecseréltem minden 2.5.13 verziószámot egy fiktív 2.5.20-ra, majd ezt az sql-t visszatöltve megnéztem. De továbbra is 2.5.13-at írt ki a vezérlőpult frissítés ellenőrzője.
Köszi.
Mellékletek:

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 16 09:28 #4 Írta: lato78
lato78 válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
Csak annyi, hogy a "honlapom_hu/joomla" egy fiktív dolog, a bejegyzés elküldése után láttam, hogy rendes link lett belőle. A tárhelyemnek nincs köze a honlapom_hu szolgáltatóhoz.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 16 10:36 #5 Írta: Balázs
Balázs válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
Elsősorban az open_basedir problémát kell leküzdeni. Ha van hozzá elég jogosultságod, akkor a Rendszer -> Rendszerinformáció -> PHP-információkon belül keress rá az open_basedir értékre, majd az ott található útvonal alapján korrigáld a configuration.php-ban található logs és tmp útvonalat. Ha nem sikerült, akkor azt javaslom, hogy kérd a szolgáltatód segítségét.

u.i.: Ne hagyj semmilyen mappán 777-es jogosultságot.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 17 17:08 #6 Írta: lato78
lato78 válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
Köszönöm.
Megnéztem az open_basedir értékét és beírtam a configuration.php-be. Most végtelen ciklus hibaüzenetet kaptam. "/" jellel indul a basedir értéke, és ha ezt kiveszem előlről, akkor visszajutok az eredeti hibaüzenethez.
Azt hiszem megfogadom a tanácsodat és valóban írok a szolgáltatónak.
Ha nem jutok vele dűlőre, akkor megfelelő frissítési mód az, hogy sima ftp-vel felülírom a most aktuális 2.5.14 verzió fájljait a "Joomla_2.5.x_to_2.5.19-Stable-Patch_Package.zip"-ben lévő fájlokkal, és utána a joomla adminon belül végrehajtok egy adatbázis javítást?
2.5.13-ról 2.5.14-re megcsináltam így még tavaly amikor kijött a 2.5.14, és hibát azóta nem tapasztaltam. És ha jó így is, akkor több verziófrissítést is át lehet ugrani így, vagy érdemes végigcsinálni verziónként a frissítést?
Köszi.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2014 márc. 17 18:52 #7 Írta: Balázs
Balázs válaszolt a témára: A Joomla! 2.5 belső frissítéskezelője JFolder::create: Az elérési út nem open_basedir elérési utakon van hibát dob.
Mindenképp érdeklődj utána, mert a Joomla! használatának egyik nagy előnye, hogy pár kattintással tudod frissíteni az alaprendszered.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!