Kérdés Editor hiba 2.5.8-ról 2.5.9-re frissítés után

Több
2013 febr. 07 16:42 #1 Írta: Isodius
Isodius létrehozta a témát: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Sziasztok!

Frissítettem az oldalam 2.5.8-ról 2.5.9-re, de míg localhost-on minden rendben volt, addig élesben az admin oldalon problémák adódtak. Bármit megnyitok, amiben szövegszerkesztő van, a következő hibát kapom:

Call to undefined method stdClass::onDisplay() in /home/szellemi/public_html/muszeion.hu/libraries/joomla/html/editor.php on line 459

A különböző fórumokon ajánlott hibajavítási módszerek nálam nem hoztak eredményt. Nem segített sem az editor váltás, sem az editorok letiltása. A felhasználói oldalon egyébként működik a szövegszerkesztő rendesen, csak az admin oldalon jelentkezik ez a hiba. (Érdekes módon, a másik weboldalamon hiba nélkül lefutott a frissítés.)

Van ötletetek, hogy ezt mi okozhatja?

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 17:23 #2 Írta: Balázs
Balázs válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Cseréld ki az adott fájt egy tiszta csomagból.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 17:38 #3 Írta: Isodius
Isodius válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Sajnos ez nem segített, ugyanaz a probléma.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 17:42 #4 Írta: Balázs
Balázs válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
1. Egy teljes 2.5.9 csomagból írtad felül?
2. Csak a Tiny nem megy?

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 17:51 #5 Írta: Isodius
Isodius válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Igen, letöltöttem a "Full" csomagot, és abból azt a bizonyos editor.php fájlt másoltam fel a szerverre.

Általában JCE-t használok, de más szerkesztővel sem megy, még a szerkesztő nélküli állapotnál is jelentkezik ez a hiba, sőt, próbáltam úgy is, hogy letiltottam a szerkesztőket, de úgy sem lett jó.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 18:12 #6 Írta: Balázs
Balázs válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Próbáld meg azt, hogy letöltöd a 2.5.9-es frissítő csomagot és telepíted a bővítménykezelőben.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 18:22 #7 Írta: Isodius
Isodius válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Igazából eredetileg is így csináltam, mert az automatikus frissítés nem tudta valamiért elindítani a letöltést magától, ezért manuálisan csináltam meg a frissítést. Azért még egyszer feltelepítettem, de semmi változás.

Szerinted, ha a teljes csomagot telepíteném, az segíthetne, vagy azzal csak több kárt okoznék?

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 18:30 #8 Írta: Balázs
Balázs válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Pont arra akartam rájáccani, hogy kézi frissítésnél besegítsen az automatikus frissítési rendszer, hibás fájlok esetén.

Biztonsági frissítésből visszahozott 2.5.8 rendesen lefrissül wampserver-en?

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 18:37 #9 Írta: Isodius
Isodius válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Nem, az automatikus frissítés alapból nem ment. De WampServer-en a kézi frissítéssel sincs gond, ám ha mindezt felmásolom a szerverre, élesbe, ott valamiért megjelenik a fent említett hiba.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2013 febr. 07 18:48 #10 Írta: Balázs
Balázs válaszolt a témára: Editor hiba 2.5.8-ról 2.5.9-re frissítés után
Ha Wampserveten engedélyezed a curlt, akkor mennie kell az automatikus frissítésnek is. Én álltalában úgy szoktam csinálni, hogy készítek egy biztonsági másolatot a működő oldalról, majd ez után az éles szerveren indítom el az automatikus frissítést.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!