Kérdés Frissítés 2.5.7-ről 2.5.8-ra

Több
2012 dec. 14 15:39 #1 Írta: k0jak
k0jak létrehozta a témát: Frissítás 2.5.7-ről 2.5.8-ra
Üdv Mindenkinek,

mindenekelőtt szeretném leszögezni, h nagyon kezdő Joomlás vagyok... :blink:

Eredetileg az aktuális weboldalra a 2.5.8-at tettem fel, amit az egyik YOOtheme sablon mintaadataival együtt telepítettem.
A telepítés után a rendszer mégis 2.5.7-et mutatott... gondoltam sebaj - tuti a yootheme demopackage még a 2.5.7-es rendszert tartalmazta, ugyanis egyszerűen felülírtam a gyökérmappát, ahogy a yootheme javasolja - majd ráfrissítek utána 2.5.8-ra. A joomla ki is írta, h van újabb frissítés, majd egy backup után rákattintottam a frissítés telepítésére (fájlok direkt felülírása módszerrel), mire kiírta,h a frissítőcsomag letöltése sikertelen. Próbáltam erre rá google-ozni, de érdemben nem találtam semmit. Vszínű, h nálam van a bibi, hiszen nem találtam hasonló hibát a neten. De vajon mi lehet a gond?
Lehet most egy amolyan felemás rendszerem lehet? 2.5.7-2.5.8? Érdekesség Adatbázis séma verziószáma: 2.5.8 Verziószám frissítése: 2.5.7 ilyet is találtam a bővítménykezelő adatbázis ellenőrzése menüpont alatt. Bár lehet ennek semmi köze...nem tudom :) lehet az ftp-n van blokkolva h rátöltsön a joomla adatokat?

Segítségeteket előre is köszönöm

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 14 17:52 - 2012 dec. 14 17:54 #2 Írta: Balázs
Balázs válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
Frissítés esetén ha a Joomla látja, hogy módosítva van egy-egy rendszerfájl, akkor azt telepítéskor ki fogja cserélni.

Amit próbálj meg:

1. Adminisztrátori felület -> Bővítmények -> Bővítménykezelő -> Adatbázis -> Javítás
2. Adminisztrátori felület -> Webhely -> Rendszer-információ -> Könyvtárengedélyek Itt Írható állapotban van az összes? Ha igen, akkor minden rendben.
3. Adminisztrátori felület -> Webhely -> Rendszer-információ -> PHP-információk Itt a curl és a fopen bekapcsolt (on) értéken van? Ha igen, akkor minden rendben.
4. Adminisztrátori felület -> Bővítmények -> Bővítménykezelő -> Frissítés -> Gyorsítótár kiürítése, majd ez után Frissítések keresése és az új verzió telepítése

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu
Utolsó szerkesztés: 2012 dec. 14 17:54 Írta: Balázs.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 14 18:39 - 2012 dec. 14 18:41 #3 Írta: k0jak
k0jak válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
Szia Balázs,

1. erre nem csinál semmit, rányomok a javításra, de semmi nem történik. itt 1 adatbázis problémát mutat: adatbázisséma verzió száma (2.5.8 ) nem egyezik a CMS verziószámával (2.5.7)
2. Egy kivételt találtam: configuration.php - nem írható
3. cURL support - enabled, ezt az fopen-t nem találom (ha jó helyen keresem : itt a PHP Version 5.3.2 után jönnek ABC sorrendben bcmath, bz2... curl...de fopen nincs, de várj a core-on belül találtam olyat, h allow_url_fopen - on. Ez lenne az?
4. ürítettem, nincs elérhető frissítés

és köszönöm szépen a villámgyors rieksönt :)
Utolsó szerkesztés: 2012 dec. 14 18:41 Írta: k0jak.

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 14 21:59 #4 Írta: Balázs
Balázs válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
Az első pontban lévő javítást végezd el rajta a jobb oldalon található Javítás gomb megnyomásával.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 14 23:50 #5 Írta: k0jak
k0jak válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
azt már megcsináltam többször is, de látszólag nem csinált semmit. Mármint nem írt ki semmi kék sávos üzenetet, h sikerrel járt vagy sem... :(

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 16 01:56 #6 Írta: Balázs
Balázs válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
Tölts le egy tiszta 2.5.8-at és a csomagban található mappákat, de csak a mappákat és az azokban lévő fájlokat írd felül a tárhelyeden lévőkkel. Természetesen csak biztonsági mentés után.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 17 12:09 #7 Írta: k0jak
k0jak válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
üdv,

átmásoltam az összes mappát - kivéve az installt - az oldal nem esett szét, de az alábbi hibákat találtam itt ott:

- Bővítmények -> Bővítménykezelő -> Adatbázis: Az adatbázis nem naprakész, az adatbázis update verzió 2.5.7 a CMS és az adatbázisséma verziója meg 2.5.8

- Bővítmények -> Bővítménykezelő -> Figyelmeztetések: A PHP ideiglenes könyvtára nincs beállítva: A PHP egy ideiglenes könyvtárat használ a feltöltött fájl tárolására mielőtt azt átadná a Joomla!-nak. Ha ez nincs beállítva és hibajelenségek tapasztalhatók a manifest fájlok vagy a feltöltött fájlok érzékelésével kapcsolatban, be kell állítani a PHP ideiglenes (temp) könyvtárát a php.ini fájlban, amely feltehetően megoldja a problémát..

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 17 12:51 #8 Írta: Balázs
Balázs válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
Próbáld meg azt, azt hogy bemész a PhpMyAdmin-ba és ott megkeresed a _schemas táblát. Ott módosítsd 700-as ID-nél, a 2.5.8-at 2.5.7-re.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 17 13:07 #9 Írta: k0jak
k0jak válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra
ööö.. és hol is van ez a PHPmyAdmin _schemes? :) 2.5.8-ról 7-re? nem fordítva?

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2012 dec. 17 13:25 #10 Írta: Balázs
Balázs válaszolt a témára: Frissítás 2.5.7-ről 2.5.8-ra

k0jak írta: ...az adatbázisséma verziója meg 2.5.8


Ha ezt egyel kisebbre rakod, akkor remélhetőleg engedi frissíteni újfent 2.5.8-ra és a frissítés helyre rakja a fájl és adatbázis struktúrát.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!