× Kereskedelmi és bolt bővítmények

Kérdés Hikashop termékexport - karakterkódolás hiba

Több
2017 jan. 04 13:28 #1 Írta: nykodesign
nykodesign létrehozta a témát: Hikashop termékexport - karakterkódolás hiba
Sziasztok!

Segítséget szeretnék kérni. Adott egy csv fájl... több száz termékkel!

Ezen termékeket szeretném beimportálni a Hikashop termékkínálatba. Minden rendben is van ezzel, bekerülnek a termékek a megfelelő kategóriába megfelelő tartalommal. Viszont azon termékek részleteire már nem lép tovább, melynek neve ékezetes karaktert tartalmaz. Tehát a listában látom, de továbblépés esetén már a terméklap helyett 404 error üzit kapok.

Amennyiben az adminisztrációban rákattintok a termékre, egy sima mentés és bezár után rendeződik a dolog... nem kell módosítanom a tartalmat, ekkor már elérem a termékleírást.

Mit tudok ilyenkor tenni? Hiszen nem szeretnék egyenként végigmenni a több száz terméken... Az importálásnál kell más karakterkészletet választanom, vagy a Hika beállításainál van hiányosság?

Köszönöm előre is!!!

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 jan. 04 14:44 #2 Írta: Balázs
Balázs válaszolt a témára: Hikashop termékexport - karakterkódolás hiba
Nézz bele, hátha segít: UTF8 import... å ä ö not working

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 jan. 04 17:56 #3 Írta: nykodesign
nykodesign válaszolt a témára: Hikashop termékexport - karakterkódolás hiba
Átfutottam párszor, de nem igazán találom a megoldást... bár bevallom nem túl erős az angolom... de lényegében itt ékezetes problémát hoz. Nekem ilyen gondolom nincs, sem az csv fájlban sem az importált termékekben, mindenhol megfelelően UTF8 kódolással megjelenik mindenféle ékezet... egyszerűen a terméklap addig nem nyílik meg, amíg én az adott terméket még egyszer a Hikashop rendszerében le nem mentettem újra... az ékezetet nem tartalmazó termékek rendben vannak.

Próbálkoztam úgy, hogy feltöltöttem admin-ból 2 terméket, majd exportáltam, töröltem és végül az export fájlt újra beimportáltam... Kezdetben ugyebár működött, importálás után már ugyan ez volt a probléma.

Tehát erre vonatkozóan is volt valami a linkelt leírásban? Mert nem volt egyértelmű... mindenféle export-import hibára találok leírásokat, de konkrétan erre nem még semmi...

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 jan. 07 00:43 #4 Írta: Balázs
Balázs válaszolt a témára: Hikashop termékexport - karakterkódolás hiba
A gond az, hogy nem sokan használnak Hikát, többek között én sem, így lehet, hogy csak a fejlesztő tudna igazán ebben a kérdésben segíteni.

Ha bizalmas információt szeretnél közölni az adminokkal, akkor tedd az üzeneted tartalmát a [ confidential ][ /confidential ] címkék közé (szóközök nélkül).

Joomla! tanácsadás, oktatás, fejlesztés - joomlabs.hu

Jelentkezz be, hogy te is részt vehess beszélgetésben!

Több
2017 febr. 02 11:50 #5 Írta: nykodesign
nykodesign válaszolt a témára: Hikashop termékexport - karakterkódolás hiba
Sikerült megoldani, így azért leírom hátha valakinek még hasznára válik:

A CSV fájban az alias (product_alias) mező nem volt kitöltve, viszont a HikaShop beállításaiban SEF url opcióknál az Alias automatikus kitöltése rész "IGEN" volt, így ő kitöltötte magának, csak az ékezetek miatt valahogy nem megfelelő karakterekkel... és itt volt a gond!

- Egyrészt bekapcsoltam a joomla globális beállításaiban az Unicode-álnevek részt.
- De ettől függetlenül még sajna nem oldódott meg a probléma, így én az exelben létrehoztam az alias oszlopot, ott függvényekkel átalakítottam a címeket amit alias-nak szerettem volna - megfelelően ékezetmentesre és úgy importáltam újra.

Az újonnan feltöltöttöt termékekkel már minden rendben volt, ha nem volt kitöltve is létrehozta szépen az alias-okat!

Jelentkezz be, hogy te is részt vehess beszélgetésben!